ASUS WLAN Adapter

ASUS WiFi-AP Solo(TM)

The ASUS WiFi-AP Solo(TM) is an easy-to-use wireless local area network (WLAN) adapter which is designed for home or office use. Direct Sequence Spread Spectrum (DSSS), Complementary Code Keying (CCK), and Orthogonal Frequency Division Multiplexing (OFDM) base band processing are implemented to support all IEEE 802.11b, and 802.11g data rates. Differential phase shift keying modulation schemes, DBPSK and DQPSK with data scrambling capability, are available, along with complementary code keying to provide data rates of 1, 2, 5.5, and 11Mbps, with long or short preamble. A high-speed Fast Fourier Transform (FFT)/Inverse Fast Fourier Transform (IFFT) combined with BPSK, QPSK, 16QAM and 64QAM modulation of the individual sub-carriers provides data rates of 6, 9, 12, 18, 24, 36, 48 and 54Mbps, with rate-compatible punctured convolution coding with a coding rate of 1/2, 2/3, and 3/4.

The ASUS WiFi-AP Solo(TM) also supports Wake-On-LAN (WOL) function and remote wake-up giving you the convenience to remote log in from other places to this system.

To provide efficient security to your wireless communication, the hardware-based IEEE 802.11i encryption/decryption engine, including 64-bit/128-bit WEP, TKIP, and AES, supports Wi-Fi alliance WPA and WPA2 security.

With these features and many more, ASUS WiFi-AP Solo(TM) is eady to connect you to the world of wireless communication.

Summery

Host system connections

Interface | Fully complies with USB 2.0 or 1.1
USB date transfer rate | USB high speed (480Mbps), and full speed (12Mbps)

Wireless LAN (WLAN) environment connections

WLAN Interface | Multimode features Fully complies with IEEE 802.11 b/g specifications
WLAN transfer rate | 802.11 b: DQPSK with data scrambling capability to provide data rate of 1, 2, 5.5, and 11Mbps 802.11 g: A high-speed Fast Fourier Transform(FFT)/Inverse Fast Fourier Transform (IFFT) provide data rate of 6, 9, 12, 18, 24, 36, 48 and 54Mbps
WLAN Frequency band | 2.4 ~ 2.497 GHz ((Industrial Scientific Medical Band)
Operation Channel | Channel 1 ~ 11
Coverage Area | Indoors: 100m with straight path Outdoors: 400m
Compatibility | Fully compatible to IEEE 802.11 a/b/g devices
Security | Hardware-based IEEE 802.11i encryption/decryption engine, including 64-bit/128-bit WEP, TKIP, and AES
Antenna | Detachable dipolar antenna
LED present (Green/Red light) | On: link is on Off: link is off Quick blinking: data transition Slow blinking with 5 times: scan wireless nodes
Wake on WLAN | Wake up system by wireless LAN (AP mode)

See Also

Supported Microsoft Windows (R) Platforms


Example decision topic

Advance Configuration Setup

In the advance page of station mode, there are several components being applied to control the hardware setting of ASUS WiFi-AP Solo.

Power Save

Turbo Mode

Fragment Threshold

RTS Threshold

Wireless Mode

802.11b Preamble Mode

Channel Plan

Power Mode

Three power modes are provided here of ASUS WiFi-AP Solo as

NONE
No consideration of the power saving

Min
Wake up every two times interval to receive packets

Max
Wake up every ten times interval to receive packets

Turbo Mode

Some 802.11b access point provide turbo mode to enhance the throughput on data transmission. If the open environment get lost noise that effect the signal quality of 2.4G radio, the turning on of turbo mode may cause frequency packet retransmit. Three options are provided here of ASUS WiFi-AP Solo as:

OFF
It always turns off the turbo mode.

ON
It always truns on the turbo mode.

AUTO
It leave the control to ASUS WiFi-AP Solo to make the better decision.

Fragment Threshold

The threshold of fragment length. Higher threshold increase data transition performance with good signal quality. Pool signal quality results more worst data throughput on high fragment threshold.

RTS Threshold

Request to send threshold. The request will not send out until the accumulated data over threshold.

Wireless Mode

Select the desired mode of wireless network to be either 802.11b mode or auto switch between 802.11b/g mode.

802.11b
802.11b provides highest transmit speed up to 11Mbps. This option will limit the ASUS WiFi-AP Solo to be 802.11b mode only.

802.11g/b
802.11b provides highest transmit speed up to 54 Mbps. This option enables ASUS WiFi-AP Solo to switch from 802.11g and b modes. Sometimes the wireless network adapter need to adjust the transmit speed to improve throughput of data transmit.

802.11 Preamble Mode

This option is only effect while wireless network adapter works on 802.11b mode.

Long
higher quality but with lower performance than preamble short mode

Short
Normal quality but with higher performance then preamble long mode.

Auto
Select the proper preamble mode by current signal frame information.

Channel Plan

The 2.4G band is a free use radio band. For wireless network, there are total 14 channels spread on this spectrum sequentially. WiFi/IEEE define 7 channel sets, called channel plans, with different combination of channels. Some country of the world had defined its own channel plan as legal wireless network channels that is also called country domain. We list the relationship below of country domain and channel plans:

Channel Plan | Channels | Country Domain
FCC | 1~11 | Argentina ,Brazil ,Colombia ,Mexico ,Taiwan ,United States of America ,Yugoslavia
IC | 1~11 | Canada
ETSI | 1~13 | Australia ,Austria , Bahrain ,Belarus ,Belgium ,Bolivia ,Bulgaria , Chile ,China ,Costa Rica ,Croatia ,Cyprus ,Czech Republic , Denmark , Egypt ,Estonia , Finland , France2 , Germany ,Greece , Hong Kong, Hungary , Iceland ,India ,Indonesia , Ireland ,Italy , Kuwait , Latvia ,Lebanon ,Liechtenstein ,Lithuania ,Luxembourg , Macedonia, The Former Yugoslav Republic of ,Malaysia , Morocco , Netherlands ,New Zealand ,Nigeria , Norway , Panama ,Paraguay ,Peru ,Philippines , Poland ,Portugal ,Puerto Rico, Romania ,Russia , Saudi Arabia ,Singapore ,Slovakia ,Slovenia , South Africa ,South Korea, Sweden ,Switzerland , Thailand ,Turkey , Uruguay ,United Kingdom , Venezuela United Arab Emirates ,
France | 10~13 | France1,Jordan
Israel | 3~9 | Israel
MKK1 | 1~14 | Japan
MKK | 14 | Japan1
Spain | 10~11 | Spain

Comment: Users may be confused with the names of some country domains and channel plans like France, France2, France1, Japan and Japan1. Due to the specific geographic location in France and Japan, some regions should consider the correlation of WiFi channels with other neighborhood country so that there are specific country domain for these regions. Users could query the relative information from relative associations and government institutions.

http://www.wi-fi.org


Example decision topic

Configuration of Security in Access Point mode

User have to define the prefer network name of this access point. The maximum length of network name can not exceed 32 characters. Each access point only could have one SSID value.

Channel and Auto Channel

The Auto channel option is enabled to select better channel that get less band sharing and interrupts. User could disable it by un-checking the box to select the desired channel number.

Security

Each authentication got opposite encryption methods as below:

Authentication | Encryption | Password Key-in Types
Open System | Disabled | Open system with disabled data encryption means there is no data protection with this connection.

WEP

Open System / WEP: There are ASCII, HEX and Passphrase three input methods. And two data encryption algorithms, 64 and 128 bits, are provided with data transmission.

ASCII: | Any ASCII are allowed to input with 5 or 13 characters.
HEX: | Only hexadecimal characters are allowed to input with 10 or 28 characters.
Passphrase: | Any ASCII are allowed to input with 1 ~ 63 characters.
Shared Key WEP Shared Key / WEP: There are ASCII, HEX and Passphrase three input methods. And two data encryption algorithms, 64 and 128 bits, are provided with data transmission.

ASCII: | Any ASCII are allowed to input with 5 or 13 characters.
HEX: | Only hexadecimal characters are allowed to input with 10 or 28 characters.
Passphrase: | Any ASCII are allowed to input with 1 ~ 63 characters.
WPA-PSK TKIP

AES

User need to input 8 ~ 63 characters as password for both TKIP and AES encryption.
WPA2-PSK TKIP

AES

See Also

Infrastructure Network
Ad-hoc network
Security


Example decision topic

Configuration of Security in Infrastructure mode

Two types network user see here are infrastructure and ad-hoc networks.

Profile Name

The name is easy to identify the opposite setting with specific environment. For example, it could be "Restroom AP", "Office" and so on.

Network Name (SSID)

The name of the network this station would join. The maximum length of SSID is 32 characters.

Channel

It provide the setting of the channel number of joined network. For infrastructure mode, the channel should follow the setting by access point instead of customization. For ad-hoc mode, it is allowed to setup the channel number either by following the present network group or creating your network group.

Wireless Network Security settings

The following introduces the security setting for infrastructure and ad-hoc networks:

  • Infrastructure authentication: Open System, Shared Key, WPA-PSK, WPA2-PSK, WPA 802.1x, WPA2 802.1x
  • Ad-hoc authentication: Open System, Shared Key and WPA-None

Each authentication got opposite encryption methods as below:

Authentication | Encryption | Password Key-in Types
Open System | Disabled | Open system with disabled data encryption means there is no data protection with this connection.

WEP

Open System / WEP: There are ASCII, HEX and Passphrase three input methods. And two data encryption algorithms, 64 and 128 bits, are provided with data transmission.

ASCII: | Any ASCII are allowed to input with 5 or 13 characters.
HEX: | Only hexadecimal characters are allowed to input with 10 or 28 characters.
Passphrase: | Any ASCII are allowed to input with 1 ~ 63 characters.
Shared Key WEP Shared Key / WEP: There are ASCII, HEX and Passphrase three input methods. And two data encryption algorithms, 64 and 128 bits, are provided with data transmission.

ASCII: | Any ASCII are allowed to input with 5 or 13 characters.
HEX: | Only hexadecimal characters are allowed to input with 10 or 28 characters.
Passphrase: | Any ASCII are allowed to input with 1 ~ 63 characters.
WPA-NONE TKIP

AES

User need to input 8 ~ 63 characters as password for both TKIP and AES encryption.
WPA-PSK TKIP

AES

User need to input 8 ~ 63 characters as password for both TKIP and AES encryption.
WPA2-PSK TKIP

AES

WPA 802.1x TKIP

AES

User need to input 8 ~ 63 characters as password for both TKIP and AES encryption. Users need to understand the other 802.1x security setting on the target access point.
WPA2 802.1x TKIP

AES

See Also

Infrastructure Network
Ad-hoc network
Security


Supported Microsoft OS

Supported Microsoft Windows (R) Platforms

ASUS WiFi-AP Solo provides two configurations, access point and client modes, to satisfy the widely usage on wireless network.

We list the supported platforms on Microsoft Windows (R) as your reference on installation.

 | Access Point | Station
Windows Server 2003 | Yes | Yes
Windows XP with service packs | Yes | Yes
Windows 2000 with service packs | Yes | Yes
Windows Millennium | N/A | Yes
Windows Server 2003 - x64 | Yes | Yes
Windows XP - x64 | Yes | Yes

See Also

ASUS WiFi-AP Solo


Wireless Network Basic Knowledge

Access point and station mode

Ad-hoc

Infrastructure


Access point and station modes

Access point and station mode

Two modes the Wi-Set wizard provides are Access point and client. Each mode own completely different feature and functionality.

Access Point Mode

In this mode, the ASUS WLAN acts as the access point that provides wireless links in the validating range to client stations to the internet.

Your system should satisfy the following two requirements to apply this mode:

  • The system you use already connects to the internet or intranet through another one Ethernet adapter.

  • You are using Windows® 2000, XP or Server2003 operation system

Station Mode

A client is an endpoint in wireless network that transmit data by connecting with access point or router via radio signal. A client could be configured as either infrastructure or Ad hoc network that dependants on your network configuration. Two network types are provided with client mode is infrastructure and ad-hoc networking.

See Also

Infrastructure network
Ad-hoc network
Wireless Network Basic Knowledge


Ad-hoc network

The Ad-hoc network is meant to easily interconnect mobile devices that are in the same area (e.g., in the same room). In this architecture, client stations are grouped into a single geographic area and can be Internet-worked without access to the wired LAN (infrastructure network). The interconnected devices in the ad hoc mode are referred to as an independent basic service set (IBSS).

See Also

Infrastructure network
Access point and station mode
Security
Wireless Network Basic Knowledge


Infrastructure network

The infrastructure network is meant to extend the range of the wired LAN to wireless cells. A laptop or other mobile device may move from cell to cell (from AP to AP) while maintaining access to the resources of the LAN. A cell is the area covered by an AP and is called a “basic service set” (BSS). The collection of all cells of an infrastructure network is called an extended service set (ESS). This first topology is useful for providing wireless coverage of building or campus areas. By deploying multiple APs with overlapping coverage areas, organizations can achieve broad network coverage. WLAN technology can be used to replace wired LANs totally and to extend LAN infrastructure.

See Also

Ad-hoc network
Access point and station mode
Security Mode
Wireless Network Basic Knowledge


Internet Connection Sharing

Internet Connection Sharing (ICS)

Internet Connection Sharing (ICS) enables a Windows computer to share its Internet connection with computers on local area networks. It's been around since Windows 98 SE, and with the launch of Windows XP, it's only gotten better.
With established Internet Connection Sharing (ICS), you can connect computers on your home or small office network to the internet through one connection. When ICS is enabled on this computer, other computers on the network with wireless/wired network connection connect to the internet through the ADSL or dial-up connection.

The ASUS WiFi-AP Solo helps you to setup ICS to enable the network connection for the rest local area network connections. After ICS is enabled, the user can use programs such as Internet Explorer or Outlook Express to connect to the Internet Service Provider (ISP).

See Also

Wireless Network Basic Knowledge
Windows 2000 ICS Setup


Wireless Network Security

Wireless Local Area Networks Security

Security is an important course with wireless network. Due to the broadband signal transmitting in the air, anyone could capture them down by specific equipments. If the transmitted data is not protected by security architecture, it should be a big risk to show your personal information to hacker around.

Two stages of wireless network security is authentication and encryption. Authentication is the first stage to allow the Wi-Fi® cline joining access point. And then all data are encrypted with specified algorithm.

Authentication

Over the past years, the Wi-Fi® Alliance has spearheaded an efforts to bring to market a standards-based interoperable security specification that would greatly increase the level of data protection and access control for Wi-Fi wireless local area networks.

  • Open system
    The WLANs you created is not protected by any security technologies. Every wireless network client could join your WLANs.

  • Shared Key
    Shared Key authentication supports authentication of STAs as either a member of those who know a shared secret key or a member of those who do not. IEEE 802.11 Shared Key authentication accomplishes this without the need to transmit the secret key in the clear; however, it does require the use of the WEP privacy mechanism. Therefore, this authentication scheme is only available if the WEP option is implemented.

  • Wi-Fi Protect Access ~ WPA(TM)
    WPA addresses all known vulnerabilities in WEP, the original, less secure 40 or 104-bit encryption scheme in the IEEE 802.11 standard. WPA also provides user authentication, since WEP lacks any means of authentication.
    WPA replaces WEP with a strong new encryption technology called Temporal Key Integrity Protocol (TKIP) with Message Integrity Check (MIC). It also provides a scheme of mutual authentication using either IEEE 802.1X/Extensible Authentication Protocol (EAP) authentication or pre-shared key (PSK) technology.

  • Wi-Fi Protect Access 2 ~ WPA2(TM)
    Launched in September 2004 by the Wi-Fi Alliance, WPA2 is the certified interoperable version of the full IEEE 802.11i specification which was ratified in June 2004. Like WPA, WPA2 supports IEEE 802.1X/EAP authentication or PSK technology. It also includes a new advanced encryption mechanism using the Counter-Mode/CBC-MAC Protocol (CCMP) called the Advanced Encryption Standard (AES).

Encryption

Encryption techniques use special technologies to scramble transmissions on one end and then unscramble them on the other. Other techniques use special keys or codes that enable the computers to talk to each other: the sender's computer transmits a key or code to the receiving computer, and if the keys match, the sender is allowed into the system.

Even though adding encryption on data packets, hackers can break encryption codes by intercepting and analyzing large amounts of data, but breaking codes takes time. By automatically "changing" the encryption keys every five minutes or so, the Wi-Fi® network is already using a new code by the time a hacker has managed to intercept and crack the old one.

  • Wired Equivalent Privacy ~ WEP
    WEP stands for Wired Equivalent Privacy, and it is an encryption system for the data that 802.11 sends through the air. WEP has two variations: 64-bit encryption (really 40-bit) and 128-bit encryption (really 104-bit). 40-bit encryption was the original standard but was found to be easily broken. 128-bit encryption is more secure and is what most people use if they enable WEP. If you are setting up a hotspot in your home, you may want to create and use a 128-bit WEP key to prevent the neighbors from casually eavesdropping on your network.
    It is the original native security mechanism for WLANs. In spite of its flaws, WEP did provide a margin of security compared to no security at all. It remained useful for deflecting eavesdroppers in home and small office/home office (SOHO) environments where network traffic is light.
    However, it was not sufficient for enterprise use. Many large companies strengthened WEP by deploying it with other third-party security solutions, including virtual private networks (VPNs), 802.1X authentication servers, and other proprietary technologies.
    By 2001, WEP's cryptographic weaknesses had become well-known. A serious of independent studies from various academic and commercial institutions had shown that an intruder equipped with the proper tools and a moderate amount of technical knowledge could gain unauthorized access to a WLAN even with WEP enabled.

  • Temporal Key Integrity Protocol ~ TKIP
    TKIP increases the size of the key from 40 to 128 bits and replaces WEP’s single static key with keys that are dynamically generated and distributed by the authentication server. TKIP uses a key hierarchy and key management methodology that removes the predictability which intruders relied upon to exploit the WEP key.

  • Message Integrity Check ~ MIC
    The Message Integrity Check (MIC) is designed to prevent an attacker from capturing data packets, altering them and resending them. The MIC provides a strong mathematical function in which the receiver and the transmitter each compute and then compare the MIC. If they do not match, the data is assumed to have been tampered with and the packet is dropped. The MIC is employed to prevent an attacker from capturing, altering and resending data packets. The MIC provides a strong mathematical function in which the receiver and the transmitter each compute and then compare the MIC.

  • Advanced Encryption Standard ~ AES
    A new advanced encryption mechanism using the Counter-Mode/CBC-MAC Protocol (CCMP) called the Advanced Encryption Standard (AES). AES satisfies U.S. government security requirements. It has been adopted as an official government standard by the U.S. Department of Commerce and the National Institute of Standards and Technology (NIST). Organizations that require the AES encryption available in WPA2 should be aware that upgrading to it may require new hardware. AES has a block size of 128 bits with 3 possible key lengths 128, 192 and 256 bits as specified in the AES standard. For the WPA2/802.11i implementation of AES, a 128 bit key length is used. AES encryption includes 4 stages that make up one round. Each round is then iterated 10, 12 or 14 times depending upon the bit-key size. For the WPA2/802.11i implementation of AES, each round is iterated 10 times.

WLANs Security Comparisons

By following the above information, we could have conclusion of WLANs security to be a table as below.

 | WEP | WPA | WPA2
Authentication | Used WEP key itself for authentication | PSK | PSK
Encryption | 40/104-bit keys WEP | 128-bits per-packet key. TKIP/MIC | 128/192/256-bits AES-CCMP
Network Types | Ad-Hoc, Infrastructure | Infrastructure | Infrastructure

See Also

Access point and station mode
Wireless Network Basic Knowledge


Example decision topic

Windows 2000 and ICS

Microsoft made a huge number of changes to their Desktop systems with the advent of Windows 2000 with nowhere the least of them made in the networking department. Still not perfect by any means, but a major step forward from the Win9x days, IMHO. One important improvement that Win2k has over Win9x is that you no longer have to reboot the PC when you change the IP address, but the improvements made to ICS over Win98SE/ME are astounding compared to that small feat! Essentially, if you install two Network Adapters in a Windows 2000 machine, Windows will allow one of them to be used for sharing it's network connection with the other adapter then being pre-set to connect to an private network. Easy.

System Requirements

An Internet service on a gateway machine can be processor intensive, depending both on the Gateway and Clients users' Internet Usage. This is probably more of an issue on a Windows machine than a Linux machine due to the fact that you need to have the Windows environment up within Windows in order to use the sharing capabilities, whereas with Linux this is not normally necessary. As Windows requires Windows to be running (!), there is a great temptation to use the ICS machine as a workstation as well, but this can cause serious performance issues when clients want to use the ICS machines services. At minimum, I recommend at least a 300Mhz system with at least 128MB of RAM. If, for whatever reason, you need to use the ICS machine as a workstation as well, then I'd suggest doubling both of those.

Like most Internet Gateways, a Windows 2000 machine requires that it has two Ethernet adapters installed, at least one of which must have a 10BaseT interface and connect to the Cable Modem using a straight RJ45 cable. The other adapter should connect to your internal network by whatever method used by the private LAN, be it RJ45, Thin/Thicknet or whatever. The information contained here uses 10baseT connectivity throughout. Like ALL gateways, it must also be switched in order for any LAN clients to be able to contact the outside world. If you do not want this situation then the only alternative is to purchase an all-in-one Gateway/Router/Firewall such as a Linksys or SMC Barricade (see the page on routers;-)).

As far as TCP/IP settings for the ICS machine, the CM attached NIC should have it's address DNS server set to be obtained automatically. The other NIC will be set, by ICS, to 192.168.0.1, so there is no need to configure anything for this. Note tho' that if you already have an address configured on NIC2 then this will be overridden when the other NIC is enabled as shared.

Clients that wish to use the ICS server need to have their TCP/IP properties set to automatic also. ICS will enable both a DHCP and a DNS service that the clients can use these to obtain their address, gateway and DNS server. Logically, the setup will look like that depicted in the following diag:

Win2K Network Diagram

Enabling Sharing

As previously stated, adding two NICs to a Windows 2000 machine adds the facility for one of them to be a shared device that other machines on a private network can also use. Consider a Windows 200o machine that contains two Local Area connections, shown as 5 and 7 in the following screen dump. Connection 5 is connected to the Local LAN and 7 is connected to the Cable Modem/ADSL, which is the interface on which sharing will be enabled.

Sharing the Connection with Cable Modem/ADSL

Selecting the properties for Connection 7 reveals the adapter and protocol settings. All protocols except TCP/IP should be unchecked on this interface, as shown below. Notice that two tabs are available in the Properties. The Sharing tab is added automatically by Windows when two network interfaces are present.

Win2K TCP/IP Properties

The properties for TCP/IP need to be set for DHCP (or, 'Obtain an IP address automatically' is ticked). In addition, DNS server addresses will also need to be set as automatic. This ensures that your ICS machine will get it's IP settings from NTL's DHCP server.

Win2k TCP/IP Properties

Selecting the Sharing tab reveals a single option - Enable Internet Connection Sharing for this connection.

Win2K NIC Share Properties

When ICS is enabled, Windows prompts a warning about changing the local LAN IP address to 192.168.0.1. Confirm that you want sharing enabled on the interface, and setup is complete!

Win2K Address Warning

The TCP/IP properties for the local LAN are reset to that shown below. No changes should be made to these properties, lest ICS is disrupted.

Win2K ICS Client TCP/IP Properties

Client TCP/IP Setup of Local LAN

Enabling ICs automatically sets your network to use 192.168.0.0 as it's network number. The hosts on your network must also use this network number as part of their IP address, with the host part being a number between 2 and 254 (1 cannot be used as the ICS machine already has that address!). ICS does provide a DHCP server, so the simplest method for getting the client PCs to connect is to set them for automatic address and DNS servers. This will result in the client PCs having both default gateway and DNS server as 192.168.0.1.

In some instances, DHCP does not work particularly well with ICS and it may be necessary to configure the client machines manually. In this case, the client needs to have the following settings:

  1. IP address is specified as 192.168.0.101 with a mask of 255.255.255.0

  2. The Gateway Address is set to 192.168.0.1

  3. The setting of DNS server is optional. If you meet problem on browsing internet, you could fill in the DNS server address that are provided by local ISP.

Subsequent machines added to the Network will also require identical settings, bar the assigned IP Address which will require the final digit to be unique. For example, addresses 192.168.0.102, 192.168.0.150 and 192.168.0.200 are all valid addresses that can be used. I would avoid using addresses in the range 192.168.0.2 to 192.168.0.100 in order to avoid any address conflicts in the event the Windows DHCP server allocates an IP address that has already been set manually on a different machine.

See Also

Internet Connection Sharing
Wireless Network Basic Knowledge